package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`menupoint\/[^\/]+$`)
var str = `aaaaaa/aaa/menupoint/example
aaaaaa/aaa/menupoint/example/example
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}