re = /[\s]{0,}@([\w]+)[ ]{1,}([\w\d]+)[ ]{0,}{.+?(?=})/
str = '@component helloWorld {
background-color: red;
padding: 1rem;
@modifier red {
color: green;
}
}
bac'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end