use strict;
my $str = '((NWS_20-12-19_FTP_VLR_01_This is a test message))
(NWS 11219 LIV TNL 02 Second test message)
(((NWS~11/12/2019~IMG-KNK-4-third_test_message)))
(NWS-12-12-19-SCR-TVM-03-Fourth-test-message))
((NWS - 12.12.2019 - FTP - CGP -5 - fifth test message)
(NWS_12.12/19~FTP-CHN 01_sixth test message ';
my $regex = qr/\(*(\w{3})[-_~\s*\.]*?(\d{1,}|\d*.\d*.\d*)[-_\s.~]*?(FTP|IMG|SCR|LIV|TVU).?-?\s?(\w{3}).\s?-?_?~?\.?(\d*).\s?-?~?_?\.?(.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}