package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*sources\/(.*)\/.*\?(.*)\/?`)
var str = `http://localhost:7776/__api/sources/KEK/content?a__contains=xyu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}