re = /.*sources\/(.*)\/.*\?(.*)\/?/m
str = 'http://localhost:7776/__api/sources/KEK/content?a__contains=xyu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end