re = /^(?!\([^()\n]*\)$|.*([()])[^()\n]*(?=\1)|[^()\n]*[()](?:[^()\n]*[()][^()\n]*[()])*[^()\n]*$|.*\([A-Z]\))\(?[A-Z](?: (?:and|or) \(?[A-Z]\)?)*$/m
str = 'A and B and C and D
(A or B) and C
(A or B or C) and D
(A or B or C or D) and E
A and (B or C) and D
A and (B or C) or (C and D)
A or (B and C)
(A and B) or (C and D)
A
A and (B) and C
A and B)
A and B and C and
(A or B and C
(A or B or C) and D or
(A or B or C or D and E
A and or (B or C) and D
A and (B or (C and D)))
A (B and C)
(A and B) or C and D)
(A and B or C and D)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end