// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(0[1-9]|[12][0-9]|3[01]):(0[1-9]|1[012]):(\d{1,4})\s+([0-1][0-9]|2[0-3]):([0-5][0-9])\s+-\s+(\w{2})").unwrap();
let string = "21:10:1999 12:12 - ss
01:10:1999 12:12 - ss
01:10:1999 23:59 - ss
01:10:1999 00:59 - ss
01:10:1999 00:61 - ss
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}