// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)name=\"(?P<name>\w+)\"\>[\w\<\/\.\>\d:]+documentation\>(?P<desc>.+?)\<\/"#).unwrap();
let string = "<xs:element name=\"ProductDescription\"><xs:annotation><xs:documentation>Provides the description of the product</xs:documentation></xs:annotation><xs:complexType><xs:sequence><xs:element name=\"ProductName\"><xs:annotation><xs:documentation>Provides a name for the product. (see list)</xs:documentation></xs:annotation><xs:simpleType><xs:restriction base=\"xs:token\"><xs:enumeration value=\"Barbie Doll\"/><xs:enumeration value=\"Ken Doll\"/></xs:restriction></xs:simpleType></xs:element><xs:element name=\"ProductSize\"><xs:annotation><xs:documentation>Describes the size of the product. (see list)</xs:documentation></xs:annotation><xs:simpleType><xs:restriction base=\"xs:token\"><xs:enumeration value=\"Small\"/><xs:enumeration value=\"Medium\"/><xs:enumeration value=\"Large\"/><xs:enumeration value=\"Dayum\"/></xs:restriction></xs:simpleType></xs:element></xs:sequence></xs:complexType></xs:element>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}