const regex = /<td class="name">\n\s+<a[^>]+>(.*)(?=<\/a>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<td class="name">\\n\\s+<a[^>]+>(.*)(?=<\\\/a>)', 'g')
const str = `<header class="ipl-header">
<div class="ipl-header__content">
<h4 name="producers" id="producers" class="ipl-header__content ipl-list-title">
Produced by
</h4>
</div>
<a class="ipl-header__edit-link" href="https://contribute.imdb.com/updates?update=tt2527336:producers">Edit</a>
</header>
<table class="subpage_data spFirst crew_list">
<tbody>
<tr class="even">
<td class="name">
<a href="/name/nm0009190/?ref_=tt_rv"
>J.J. Abrams</a>
</td>
<td>...</td>
<td>executive producer</td>
</tr>
<tr class="odd">
<td class="name">
<a href="/name/nm0027297/?ref_=tt_rv"
>Pippa Anderson</a>
</td>
<td>...</td>
<td>co-producer</td>
</tr>
</tbody>
</table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}