# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(:)(\s+\$+.*;)"
test_str = (".dabur-india{\n"
" color: $color-brand-group-3-light !important;\n"
" .mmm{\n"
" background: $color-brand-group-2-dark;\n"
" $border-dark: rgba($base-color, 0.88);\n"
" .alert {\n"
" border: 1px solid $border-dark;\n"
" }\n"
" }\n"
"}\n\n"
"$black: #000 !default;\n"
"$border-radius: 0.25rem !default;\n"
"$box-shadow: 0 0.5rem 1rem rgba($black, 0.15) !default;\n\n"
"code {\n"
" border-radius: $border-radius;\n"
" box-shadow: $box-shadow;\n"
"}\n\n"
"@if $dark-theme {\n"
" $primary-color: darken($primary-color, 60%);\n"
" $accent-color: lighten($accent-color, 60%);\n"
"}\n\n"
"$theme-colors: (\n"
" \"success\": #28a745,\n"
" \"info\": #17a2b8,\n"
" \"warning\": #ffc107,\n"
");\n\n"
".alert {\n"
" // Instead of $theme-color-#{warning}\n"
" background-color: map.get($theme-colors, \"warning\");\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.