Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<=class=["'][\w\- :\.]*)([\w\-:\.]+)
/
gm
Input 1
1
New
<div class="px-4 sm:px-6 lg:px-8"> <div class="sm:flex sm:items-center"> <div class="sm:flex-auto"> <h1 class="text-xl font-semibold text-gray-900">Users</h1> <p class="mt-2 text-sm text-gray-700">A list of all the users in your account including their name, title, email and role.</p> </div> <div class="mt-4 sm:mt-0 sm:ml-16 sm:flex-none"> <button type="button" class="inline-flex items-center justify-center rounded-md border border-transparent bg-indigo-600 px-4 py-2 text-sm font-medium text-white shadow-sm hover:bg-indigo-700 focus:outline-none focus:ring-2 focus:ring-indigo-500 focus:ring-offset-2 sm:w-auto">Add user</button> </div> </div> <div class="mt-8 flex flex-col"> <div class="-my-2 -mx-4 overflow-x-auto sm:-mx-6 lg:-mx-8"> <div class="inline-block min-w-full py-2 align-middle"> <div class="overflow-hidden shadow-sm ring-1 ring-black ring-opacity-5"> <table class="min-w-full divide-y divide-gray-300"> <thead class="bg-gray-50"> <tr> <th scope="col" class="py-3.5 pl-4 pr-3 text-left text-sm font-semibold text-gray-900 sm:pl-6 lg:pl-8">Name</th> <th scope="col" class="px-3 py-3.5 text-left text-sm font-semibold text-gray-900">Title</th> <th scope="col" class="px-3 py-3.5 text-left text-sm font-semibold text-gray-900">Email</th> <th scope="col" class="px-3 py-3.5 text-left text-sm font-semibold text-gray-900">Role</th> <th scope="col" class="relative py-3.5 pl-3 pr-4 sm:pr-6 lg:pr-8"> <span class="sr-only">Edit</span> </th> </tr> </thead> <tbody class="divide-y divide-gray-200 bg-white"> <tr> <td class="whitespace-nowrap py-4 pl-4 pr-3 text-sm font-medium text-gray-900 sm:pl-6 lg:pl-8">Lindsay Walton</td> <td class="whitespace-nowrap px-3 py-4 text-sm text-gray-500">Front-end Developer</td> <td class="whitespace-nowrap px-3 py-4 text-sm text-gray-500">lindsay.walton@example.com</td> <td class="whitespace-nowrap px-3 py-4 text-sm text-gray-500">Member</td> <td class="relative whitespace-nowrap py-4 pl-3 pr-4 text-right text-sm font-medium sm:pr-6 lg:pr-8"> <a href="#" class="text-indigo-600 hover:text-indigo-900">Edit<span class="sr-only">, Lindsay Walton</span></a> </td> </tr> <!-- More people... --> </tbody> </table> </div> </div> </div> </div> </div>
Substitution