// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^HAD(?:-OR(?:AAS|BTD)[0-9]{5,7}){1,2}$").unwrap();
let string = "HAD-ORAAS0001545-ORBTD0003457
HAD-ORBTD0001545-ORAAS0003457";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}