re = /\/\/[^\r\n]*(*SKIP)(*F)|background:\s*(?!transparent|none)\w+/m
str = 'background: #fff; // should not be found
background: transparents; // should not be found, but is found
// background: blue; background: blue; // should be found
background: blue;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end