# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^?#]+).*"
test_str = ("https://studio.grabyo.com/home.jsp#stream/fBCyXMbtgHQ/share\n"
"https://studio.grabyo.com/studiolibrary.jsp?channelId=hkWw8oRUtPA\n"
"https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs&streamId=TCiHdVdqoBe\n"
"https://studio.grabyo.com/studiolibrary.jsp?streamId=TCiHdVdqoBe&galleryId=AQiJBGfoaJs\n"
"https://studio.grabyo.com/studiolibrary.jsp?campaignId=qzNPNPKTmry\n"
"https://studio.grabyo.com/trim.jsp?channelId=1dnc0Cjw9Ze\n"
"https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.