#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^#\s(\d+)\s+-?(\d{2}):(\d{2})\.(\d{3})\s(\d+)\s(\d{2}:\d{2})$"
Local $sString = "StNr Laptime Lap Tageszeit" & @CRLF & _
"# 665 -02:04.137 6 10:52" & @CRLF & _
"# 665 -01:47.625 5 10:50" & @CRLF & _
"# 665 -01:49.546 4 10:48" & @CRLF & _
"# 665 -01:57.014 3 10:47" & @CRLF & _
"# 665 -01:51.407 2 10:45" & @CRLF & _
"# 665 -00:00.000 1 10:43" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")