using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"^#\s(\d+)\s+-?(\d{2}):(\d{2})\.(\d{3})\s(\d+)\s(\d{2}:\d{2})$";
        string input = @"StNr      Laptime       Lap     Tageszeit
# 665	-02:04.137	6	10:52
# 665	-01:47.625	5	10:50
# 665	-01:49.546	4	10:48
# 665	-01:57.014	3	10:47
# 665	-01:51.407	2	10:45
# 665	-00:00.000	1	10:43
";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}