^start of line
#the literal # (3510 / 438 / 2316)
\sany whitespace character
\d+a digit, repeated at least once
\s+any whitespace character, repeated at least once
-?optionally matches the literal - (4510 / 558 / 2D16)
\d{2}a digit, repeated exactly 2 times
:the literal : (5810 / 728 / 3A16)
\d{2}a digit, repeated exactly 2 times
\.the literal . (4610 / 568 / 2E16)
\d{3}a digit, repeated exactly 3 times
\sany whitespace character
\d+a digit, repeated at least once
\sany whitespace character
\d{2}a digit, repeated exactly 2 times
:the literal : (5810 / 728 / 3A16)
\d{2}a digit, repeated exactly 2 times
$end of line
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string