// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^#\s(\d+)\s+-?(\d{2}):(\d{2})\.(\d{3})\s(\d+)\s(\d{2}:\d{2})$").unwrap();
let string = "StNr Laptime Lap Tageszeit
# 665 -02:04.137 6 10:52
# 665 -01:47.625 5 10:50
# 665 -01:49.546 4 10:48
# 665 -01:57.014 3 10:47
# 665 -01:51.407 2 10:45
# 665 -00:00.000 1 10:43
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}