#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)( " & @CRLF & _
" (\+\d-\d{3}-\d{3}-\d{4}) (?# telefone)" & @CRLF & _
" \s ([\w\s\.]+) \s (?# endereço)" & @CRLF & _
" (\<\p{Lu}\s\p{Lu}\p{Ll}+\>) (?# nome)" & @CRLF & _
") " & @CRLF & _
"|" & @CRLF & _
"( (.+?) (?# parte do endereço)" & @CRLF & _
" ((?4)) (?# reaproveita a regex do nome)" & @CRLF & _
" (.+?) (?# parte 2 endereço)" & @CRLF & _
" ((?2)) (?# reaproveita a regex do telefone)" & @CRLF & _
")" & @CRLF & _
""
Local $sString = "+1-541-754-3010 156 Alphand_St. <J Steeve>" & @CRLF & _
"133, Green, Rd. <E Kustur> NY-56423 ;+1-541-914-3010"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")