package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?://(mobile\.|www\.)?(twitter|x)\.com([\w/-]+)`)
var str = `https://twitter.com/lorem↵
https://www.twitter.com/ipsum↵
https://x.com/dolor↵
https://mobile.x.com/sit↵
https://fedex.com/amet↵
https://www.fedex.com/consectetur`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}