import Foundation
let pattern = #"https?://(mobile\.|www\.)?(twitter|x)\.com([\w/-]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://twitter.com/lorem↵
https://www.twitter.com/ipsum↵
https://x.com/dolor↵
https://mobile.x.com/sit↵
https://fedex.com/amet↵
https://www.fedex.com/consectetur
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)