#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{5}\s{6}[\s\*](?:[^.:;()]*|(?<!\s)[.:;]|\((?!\s)|(?<!\s)\))*$"
Local $sString = "00000 *TEST .FINAL STATEMENT." & @CRLF & _
"00001 *TEST2 . FINAL STATEMENT." & @CRLF & _
"00002 *TEST3. FINAL STATEMENT."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")