const regex = /^\d{5}\s{6}[\s\*](?:[^.:;()]*|(?<!\s)[.:;]|\((?!\s)|(?<!\s)\))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{5}\\s{6}[\\s\\*](?:[^.:;()]*|(?<!\\s)[.:;]|\\((?!\\s)|(?<!\\s)\\))*$', 'gm')
const str = `00000 *TEST .FINAL STATEMENT.
00001 *TEST2 . FINAL STATEMENT.
00002 *TEST3. FINAL STATEMENT.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}