import Foundation
let pattern = #"^\d{5}\s{6}[\s\*](?:[^.:;()]*|(?<!\s)[.:;]|\((?!\s)|(?<!\s)\))*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
00000 *TEST .FINAL STATEMENT.
00001 *TEST2 . FINAL STATEMENT.
00002 *TEST3. FINAL STATEMENT.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)