$re = '/#(\w+)/m';
$str = '#1, #1A, #A1';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;