const regex = /(?<=[, ])myTable(?=[^2])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[, ])myTable(?=[^2])', 'gm')
const str = `select myTable.x,myTable.y,myTable.myTable from myTable join myTable2 ON myTable.x = myTable2.x
`;
const subst = `myTable3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);