use strict;
my $str = 'apple with make,up things $312,412,3.00';
my $regex = qr/(\d),(?=\d)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";