$re = '/(\d),(?=\d)/m';
$str = 'apple with make,up things $312,412,3.00';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;