using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s?(\w+)(?=:)";
string input = @"Martin: Let's show Mr. Hooper our, uh, hex. Here. "" +
""Hooper: Ah, victim identified as Christine Watkins. Female Caucasian. "" +
""Martin: Yeah now, now here's where we have it. "" +
""Hooper: Probable boating accident. Martin: Yeah. "" +
""Hooper: The height and weight of the victim can only be estimated from the partial remains. The torso has been severed in mid-thorax. There are no major organs remain.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}