use strict;
my $str = 'Martin: Let\'s show Mr. Hooper our, uh, hex. Here. " +
"Hooper: Ah, victim identified as Christine Watkins. Female Caucasian. " +
"Martin: Yeah now, now here\'s where we have it. " +
"Hooper: Probable boating accident. Martin: Yeah. " +
"Hooper: The height and weight of the victim can only be estimated from the partial remains. The torso has been severed in mid-thorax. There are no major organs remain.';
my $regex = qr/\s?(\w+)(?=:)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}