re = /\s?(\w+)(?=:)/m
str = 'Martin: Let\'s show Mr. Hooper our, uh, hex. Here. " +
"Hooper: Ah, victim identified as Christine Watkins. Female Caucasian. " +
"Martin: Yeah now, now here\'s where we have it. " +
"Hooper: Probable boating accident. Martin: Yeah. " +
"Hooper: The height and weight of the victim can only be estimated from the partial remains. The torso has been severed in mid-thorax. There are no major organs remain.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end