import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<FO_KEP>[^<]*<\\/FO_KEP>)\\r?\\n(<OSSZESZERELESI_KEP>[^<]*<\\/OSSZESZERELESI_KEP>)";
final String string = "<TERMEK>\n"
+ "<TERMEK_KOD>01008213</TERMEK_KOD>\n"
+ "<FO_KEP>https://www.temponabytok.sk/Files/obrazky/01008213.jpg</FO_KEP>\n"
+ "<OSSZESZERELESI_KEP>https://www.temponabytok.sk/Files/dokumenty/Vratko_montazny_navod.jpg</OSSZESZERELESI_KEP>\n"
+ "<OBRAZKY>https://www.temponabytok.sk/Files/2341000/2341428/245320712.jpg</OBRAZKY>\n"
+ "</TERMEK>";
final String subst = "\\2\\n\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}