$re = '~/\*.*?\*/(*SKIP)(*FAIL)|,~';
$str = 'var1 /* first, variable */, var2, var3 /* third, variable */
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);