using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(<string name=\""){1}[\w.]+(\"">){1}[\w ]+(?i)yoti(</string>){1}";
string input = @"<string name=""loc.component.help.email.label"">Email EasyID</string>
<string name=""loc.component.help.email.label"">Email EasyID</string>
<string name=""loc.component.yoti.help.email.label"">Email EasyID</string>
<string name=""loc.component.help.email.label"">Email yoti</string>
<string name=""loc.component.help.email.label"">Email YoTi</string>
<string name=""loc.component.help.email.label"">Email YOTI</string>
<string name=""loc.component.help.email.label"">Email YO.TI</string>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}