# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\s,]*[-*\/+\d]+/\n/gm;t' <<< "quanity*price/2+tax
quanity*price/2
quanity , *price/2+tax
quanity - *price,/2
quanity -, -- , *price,/2
quantity - 3 //,,/price"