$re = '~[\s,]*[-*/+\d]+~m';
$str = 'quanity*price/2+tax
quanity*price/2
quanity , *price/2+tax
quanity - *price,/2
quanity -, -- , *price,/2
quantity - 3 //,,/price';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;