import Foundation
let pattern = #"[\s,]*[-*/+\d]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
quanity*price/2+tax
quanity*price/2
quanity , *price/2+tax
quanity - *price,/2
quanity -, -- , *price,/2
quantity - 3 //,,/price
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)