package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[#]{1,5}\s[\w\s]*(?:\*[\w\s]+\*|(?:\*\*[\w\s]+\*\*))`)
var str = `## *test*
# ** this is some **
# some other** this is some **
##### this is ok`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}