re = /^[#]{1,5}\s[\w\s]*(?:\*[\w\s]+\*|(?:\*\*[\w\s]+\*\*))/m
str = '## *test*
# ** this is some **
# some other** this is some **
##### this is ok'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end