# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"educacao\/busca-?([\w%-]+)?\/?(?!em-)([\w%-]+)?\/?(em-)?([\w%-]+)?\/?"
test_str = ("###################\n\n"
"# bug cases\n"
"https://www.catho.com.br/educacao/busca/em-em-em-em-extrema-mg\n"
"https://www.catho.com.br/educacao/busca/em-extrema-mg\n"
"https://www.catho.com.br/educacao/busca/em-mextrema-mg\n"
"https://www.catho.com.br/educacao/busca-curso-admin/usp/em-mextrema-mg\n"
"https://www.catho.com.br/educacao/busca-curso-admin/em-mextrema-mg\n"
"https://www.catho.com.br/educacao/busca-admin/em-mextrema-mg\n\n"
"#####################\n\n"
"// without term or filters\n"
"https://www.catho.com.br/educacao/busca\n"
"https://www.catho.com.br/educacao/busca/\n\n"
"###################\n\n"
"// with term or match but no filters\n"
"https://www.catho.com.br/educacao/busca-curso-design-industrial\n"
"https://www.catho.com.br/educacao/busca-curso-design-industrial/\n"
"https://www.catho.com.br/educacao/busca-de%20csign-industrial\n"
"https://www.catho.com.br/educacao/busca-de%20csign-industrial/\n"
"https://www.catho.com.br/educacao/busca-design-industrial\n"
"https://www.catho.com.br/educacao/busca-design-industrial/\n\n"
"###################\n\n"
"// without term but with provider\n"
"https://www.catho.com.br/educacao/busca/centro-universitario-senac\n"
"https://www.catho.com.br/educacao/busca/centro-universitario-senac/\n\n"
"// without term but with location\n"
"https://www.catho.com.br/educacao/busca/em-sao-paolo\n"
"https://www.catho.com.br/educacao/busca/em-sao-paolo/\n\n"
"// without term but with provider & location\n"
"https://www.catho.com.br/educacao/busca/centro-universitario-senac/em-sao-paolo\n"
"https://www.catho.com.br/educacao/busca/centro-universitario-senac/em-sao-paolo/\n\n"
"###################\n\n"
"// with term & provider\n"
"https://www.catho.com.br/educacao/busca-design-industrial/centro-universitario-senac\n"
"https://www.catho.com.br/educacao/busca-design-industrial/centro-universitario-senac/\n\n"
"// with term & location\n"
"https://www.catho.com.br/educacao/busca-design-industrial/em-sao-paolo\n"
"https://www.catho.com.br/educacao/busca-design-industrial/em-sao-paolo/\n\n"
"// with term & provider & location\n"
"https://www.catho.com.br/educacao/busca-design-industrial/centro-universitario-senac/em-sao-paolo\n"
"https://www.catho.com.br/educacao/busca-design-industrial/centro-universitario-senac/em-sao-paolo/\n\n"
"###################\n\n"
"// with match & provider\n"
"https://www.catho.com.br/educacao/busca-curso-design-industrial/centro-universitario-senac\n"
"https://www.catho.com.br/educacao/busca-curso-design-industrial/centro-universitario-senac/\n\n"
"// with match & location\n"
"https://www.catho.com.br/educacao/busca-curso-design-industrial/em-sao-paolo\n"
"https://www.catho.com.br/educacao/busca-curso-design-industrial/em-sao-paolo/\n\n"
"// with match & provider & location\n"
"https://www.catho.com.br/educacao/busca-curso-design-industrial/centro-universitario-senac/em-sao-paolo\n"
"https://www.catho.com.br/educacao/busca-curso-design-industrial/centro-universitario-senac/em-sao-paolo/")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.