re = /educacao\/busca-?([\w%-]+)?\/?(?!em-)([\w%-]+)?\/?(em-)?([\w%-]+)?\/?/
str = '###################
# bug cases
https://www.catho.com.br/educacao/busca/em-em-em-em-extrema-mg
https://www.catho.com.br/educacao/busca/em-extrema-mg
https://www.catho.com.br/educacao/busca/em-mextrema-mg
https://www.catho.com.br/educacao/busca-curso-admin/usp/em-mextrema-mg
https://www.catho.com.br/educacao/busca-curso-admin/em-mextrema-mg
https://www.catho.com.br/educacao/busca-admin/em-mextrema-mg
#####################
// without term or filters
https://www.catho.com.br/educacao/busca
https://www.catho.com.br/educacao/busca/
###################
// with term or match but no filters
https://www.catho.com.br/educacao/busca-curso-design-industrial
https://www.catho.com.br/educacao/busca-curso-design-industrial/
https://www.catho.com.br/educacao/busca-de%20csign-industrial
https://www.catho.com.br/educacao/busca-de%20csign-industrial/
https://www.catho.com.br/educacao/busca-design-industrial
https://www.catho.com.br/educacao/busca-design-industrial/
###################
// without term but with provider
https://www.catho.com.br/educacao/busca/centro-universitario-senac
https://www.catho.com.br/educacao/busca/centro-universitario-senac/
// without term but with location
https://www.catho.com.br/educacao/busca/em-sao-paolo
https://www.catho.com.br/educacao/busca/em-sao-paolo/
// without term but with provider & location
https://www.catho.com.br/educacao/busca/centro-universitario-senac/em-sao-paolo
https://www.catho.com.br/educacao/busca/centro-universitario-senac/em-sao-paolo/
###################
// with term & provider
https://www.catho.com.br/educacao/busca-design-industrial/centro-universitario-senac
https://www.catho.com.br/educacao/busca-design-industrial/centro-universitario-senac/
// with term & location
https://www.catho.com.br/educacao/busca-design-industrial/em-sao-paolo
https://www.catho.com.br/educacao/busca-design-industrial/em-sao-paolo/
// with term & provider & location
https://www.catho.com.br/educacao/busca-design-industrial/centro-universitario-senac/em-sao-paolo
https://www.catho.com.br/educacao/busca-design-industrial/centro-universitario-senac/em-sao-paolo/
###################
// with match & provider
https://www.catho.com.br/educacao/busca-curso-design-industrial/centro-universitario-senac
https://www.catho.com.br/educacao/busca-curso-design-industrial/centro-universitario-senac/
// with match & location
https://www.catho.com.br/educacao/busca-curso-design-industrial/em-sao-paolo
https://www.catho.com.br/educacao/busca-curso-design-industrial/em-sao-paolo/
// with match & provider & location
https://www.catho.com.br/educacao/busca-curso-design-industrial/centro-universitario-senac/em-sao-paolo
https://www.catho.com.br/educacao/busca-curso-design-industrial/centro-universitario-senac/em-sao-paolo/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end