use strict;
my $str = 'apple|pear
apple|quince
apple cider|juice
banana|plantain
cherry|cheerful, crimson
cherry|ruddy
cherry|cerise
';
my $regex = qr/^(.+?)\|.*[^ ]\K *\r?\n\1/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";