#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mysi)([\-]*BEGIN\sCERTIFICATE\sREQUEST[\-]+.+[-]+END\sCERTIFICATE\sREQUEST[-]+)"
Local $sString = "-----BEGIN CERTIFICATE REQUEST-----" & @CRLF & _
"MIIEuDCCAqACAQAwczELMAkGA1UEBhMCVVMxGDAWBgNVBAMMD3BsdWdpYmlsaXR5" & @CRLF & _
"LmNvbTEXMBUGA1UEBwwOU2FsdCBMYWtlIENpdHkxFDASBgNVBAoMC1BsdWdpYmls" & @CRLF & _
"aXR5MQ0wCwYDVQQIDARVdGFoMQwwCgYDVQQLDANPcmcwggIiMA0GCSqGSIb3DQEB" & @CRLF & _
"AQUAA4ICDwAwggIKAoICAQCfQqx8YexJ4HjGqIpywxvTOPDnqIaZicD3IQSUdAb5" & @CRLF & _
"5vcfAaD/0KBH/6Oa2NPlq4mYAw2octDiuklvkXIUgnn85vwlj6fLm6iR6i1tjM3g" & @CRLF & _
"tusxur3fmMdF9YqDNNM7LVSxXMq/vXuChPj3bVib2EyKJRcBn8EMTnJYdfl3YK4l" & @CRLF & _
"j+KW7cnxIy8E3DAy4KIUPbI2LNPix43emW6XuMB3hpvcbs2YpQogagAQwvNYAIcW" & @CRLF & _
"Ub3+fSEbXFNVmYFRPbd7T5Arei4Ubl8kKVWfqUnWIOdYQh7o0CbQl+67ivAyRnDU" & @CRLF & _
"oItNtPz+seWzL1xerjQqdlHrCQFGNfLdI3Hfl9SZVKOqdsjs2bEiP+C6E/pilvu/" & @CRLF & _
"zEtD5VbGd0UBBZtANm6BdBEhhigX8vL/FfiqxlPsEK31L9tQnwa6ETvcVbRQoXBW" & @CRLF & _
"idJJKCmiScz17ML8aTxw0zXc16CBHuE4AEV7xaNmdl5NsYCB+q/H3SCVsreMnu7A" & @CRLF & _
"cpCgvaCZX1/8zSWrVNMf0i+/gJCoBh1OXNnqtCPycJDPvrVGYF2U7RqzC4c91Kqe" & @CRLF & _
"QxEKHApEJAL47nFtM9c3K2fNvLEVOD+k+iDkEuL++VHaXO3VHCiVoJjQCSNTChl3" & @CRLF & _
"aSL29LadjcPvf2QdMymEJ4+wKI8u6l1bk51zN0INnVDDkMdtfCu0C8ux8M4roP9Y" & @CRLF & _
"kQIDAQABoAAwDQYJKoZIhvcNAQELBQADggIBAJO3HIp2hvkQh6/Bk19RiEdyfJjb" & @CRLF & _
"xoPWtfM4lWDyXLxq6HrmKadvOtjTs9fGpoBRJaknIhy8n0/oN8Et+uFgga3ptb/8" & @CRLF & _
"AjyDRVqmYK3byAJrUm055v9VseNwFqE/hsZiFtPMVA5I5agtnQm8o6zPgUSMQWso" & @CRLF & _
"evA00Fa+Q1X1Hmbthtd2ZH64cxLOqW3vW9LViBp9C52mU1NyZtvPRJAlcOlH1r9A" & @CRLF & _
"MFnPrR7T4HJ8gMEvaj0likFr5nQKWH5ScPvHbIKyIoebn9RznbMZBNjUn60+I0Kt" & @CRLF & _
"VwN8UrIwZMNF+eL99I6kEr/gjoZ3VegPH7YaVRQ280L4NvZNKMbAr1Z+uyCD587y" & @CRLF & _
"Zf+cbzZB30xTfra0/iUQnGEBuScpGQMdXEzmE/lBCnNnqnNohrAwvQNLISbnK7w2" & @CRLF & _
"JUrwbIIgRrLmmXGELPQ7vBkKmCtSrmPGLyWctwG005h8hHLtFk8jagSDJ/gTQ3Wv" & @CRLF & _
"n7YEy3ROHujz/UVGrGE2P3oKs5prn+N52HIxM9XoaQndrtbyvkaOe+WHGZ0htQkE" & @CRLF & _
"H6Rrh0YijAFpZTsKwv1ndMh2HpoaYX3B1s9ky3TWGAdOMCgHgdBFpvk2+PdDN+6a" & @CRLF & _
"Js+0VtfRywLxxaEamLciBj6JmjybIEBSANSwf2pdn8OnMq5BLZrLRWhsaMVGlciL" & @CRLF & _
"1JPHcsgLz1lD8FYC" & @CRLF & _
"-----END CERTIFICATE REQUEST-----" & @CRLF & _
"" & @CRLF & _
"-----BEGIN PRIVATE KEY-----" & @CRLF & _
"MIIJQgIBADANBgkqhkiG9w0BAQEFAASCCSwwggkoAgEAAoICAQCfQqx8YexJ4HjG" & @CRLF & _
"qIpywxvTOPDnqIaZicD3IQSUdAb55vcfAaD/0KBH/6Oa2NPlq4mYAw2octDiuklv" & @CRLF & _
"kXIUgnn85vwlj6fLm6iR6i1tjM3gtusxur3fmMdF9YqDNNM7LVSxXMq/vXuChPj3" & @CRLF & _
"bVib2EyKJRcBn8EMTnJYdfl3YK4lj+KW7cnxIy8E3DAy4KIUPbI2LNPix43emW6X" & @CRLF & _
"uMB3hpvcbs2YpQogagAQwvNYAIcWUb3+fSEbXFNVmYFRPbd7T5Arei4Ubl8kKVWf" & @CRLF & _
"qUnWIOdYQh7o0CbQl+67ivAyRnDUoItNtPz+seWzL1xerjQqdlHrCQFGNfLdI3Hf" & @CRLF & _
"l9SZVKOqdsjs2bEiP+C6E/pilvu/zEtD5VbGd0UBBZtANm6BdBEhhigX8vL/Ffiq" & @CRLF & _
"xlPsEK31L9tQnwa6ETvcVbRQoXBWidJJKCmiScz17ML8aTxw0zXc16CBHuE4AEV7" & @CRLF & _
"xaNmdl5NsYCB+q/H3SCVsreMnu7AcpCgvaCZX1/8zSWrVNMf0i+/gJCoBh1OXNnq" & @CRLF & _
"tCPycJDPvrVGYF2U7RqzC4c91KqeQxEKHApEJAL47nFtM9c3K2fNvLEVOD+k+iDk" & @CRLF & _
"EuL++VHaXO3VHCiVoJjQCSNTChl3aSL29LadjcPvf2QdMymEJ4+wKI8u6l1bk51z" & @CRLF & _
"N0INnVDDkMdtfCu0C8ux8M4roP9YkQIDAQABAoICAGRnX2DnR1Vn/ByaQvaJBPDM" & @CRLF & _
"NCyINZt0mj/zA/UnlQJV1zQoDb1ZZMMfaqCD1Es2Mv+v5RtujzxxXzzEQFynyYpk" & @CRLF & _
"gVCY2Ztmngan0U4AeAcUqwBmD7B4nCEB5PpFAmqLcJqEupnZNpWZiXBL8pIF8nMh" & @CRLF & _
"YPi4I7fDeRlF/ymAvSmXJa4raaXpnYn92zEoJ2aFYuX+qvKNBmbw6iUi58wzA+4b" & @CRLF & _
"uOhkHBdFXJc0oL+5TXEHxbU8Y/Pg5/TOWxXBx/wos+aFF6nvz3F30bBfxNoHUnJ0" & @CRLF & _
"9RGnsODO+EYqGLZJbHbQZCJwWROlSgAGesCCKQcgIxL/UVtXRa6e2vqwuOqVzrv5" & @CRLF & _
"msBFM/HzcUvdtNq4FP2UfcqAi4FZlwHlbTDphE3fZSPbLIoJZLuhKuJPFA/Sc8L/" & @CRLF & _
"ABPnmRqb0bZ2RKECBnXrsV0U/KeSxbY4r0Hj+ggBnLNO1VhlYjCQZlCXA4X8LdyV" & @CRLF & _
"wBvoNeKjSo3ZD8vr/Jvpdm/9xiWVikbPqYpiEiIn6iN8omYWjxHWgDox9fd+zVQu" & @CRLF & _
"c/3giKEVAQYhNYj+YbkZpmnWQNjdL89TatjdBeaWO9Zq4k1VwN5UYB539O61kHfC" & @CRLF & _
"bhpYx/ptIgTBdEwp+ohlkAegCyBS+Mo3SiQocATdpeBwAMoMpMOtCiMDyGjydK0Y" & @CRLF & _
"2xi5+uOGMDKMbWvRe10FAoIBAQDMnaqknzt8Brc1KHQVv7Ww0VTrCEjItXLaAIOs" & @CRLF & _
"AW9PyL6/9lhFYljCnEGcWL3LAZlhldr81aNE40qw5FVVRrTR2Hg3xF/znZwa6Bnc" & @CRLF & _
"0t1XXGRj0BZIH5OrZSdf0gXdEwIrIB2LmllxMMpzd0BSgX/+x6k2K6FMAl/048bg" & @CRLF & _
"v986GsRwUjrlkt0ihyQNHlWuKKK82W1G6G4iQiC0bD5i/AUBer9o5Yb4X9GrgoIA" & @CRLF & _
"nWJIHstfJ80KTOJMQVczj0SKLmTjnIUE91BcXGhqTTdcSKTWbts50HyuwQAYcZco" & @CRLF & _
"vW5B5Sbyf57jCvu68Bo3gxngE1xYjtTR6Q13azII4DxyE7MjAoIBAQDHQTMNW8NQ" & @CRLF & _
"unvr64yqCwzBmEmpCJ6NEbYub3rqHzQPe5Na5VN1iTujKx5ifhi5uhR5A5Jluy2O" & @CRLF & _
"fUWzF/ihEdVOOh0JPj1NiJkY1VkuiY9Y2aHR2+8st06sp92Zj1i7Us/t+CP+WuOv" & @CRLF & _
"m7He4xRRrXx9tXcdpAzaTr8NoKXCL1fz4t8HKUZdfvvCtY+Ghd3ct1rEG8Bi9SUF" & @CRLF & _
"yBoTE1NwATHLCsYFURhpmWwnQTMpRTjlhogNSywDG59fdcqyEBUacCnPG7ZxZ3c2" & @CRLF & _
"N8VWknZsf9hBEyjyGCvTNq1A0KKJ6PIEp2gOoMi4I1nbKB1jSC7Gh61pJ+aV4L6g" & @CRLF & _
"M10Jh890RWq7AoIBAQC8vvv4G0Jd6Dv79zMOFOffEVpJ7DxnmKk3W54afsBVUpJS" & @CRLF & _
"tUU7y7qg2k7TkDCTIQiBsiBtdgzDsP7nKdllbnHB2PMcTjNMoCit0Uh6ILE4suuP" & @CRLF & _
"/xVutmIbipXFmBD8m1o2uctHSbwT47P8yxY0hWyycy8t3xVM7ivh1HNSQuwBx0tJ" & @CRLF & _
"aTEXMGB4Rz0ENOVIYAeuOMrKzAE77NAKXoc1+9AKS1Zhxsi4OHtKwHp3YraUXIOx" & @CRLF & _
"ZR+Izt85BFUSJKhO5vj91RYHPLOOX1eaJ1xX7lLP0za6oA1Djpkt8ypC1Grushk5" & @CRLF & _
"PGwud6U6Dd3BM1gdEP7wWeELOPXJIMLo2SApAu8NAoIBAGjYmPl9gJ/ZEN4KOyE6" & @CRLF & _
"4UJ5VME6RNusJzX1+TJ6qtU+zEH3C9x8EsKALOPcwDvye1VWGNGpFYa1ylg709tF" & @CRLF & _
"W/1mvOKhOnay2wRjNyMyxRgWpHyeAxN/fUmCpytnb2RaZgktGht8TfSYs5a53HZC" & @CRLF & _
"GJC5TO1u5kh1STjtgGtWqCwwA/VrtZf6+pTxHo3FoQHEBWHNzIUFw65wJbBF6hC0" & @CRLF & _
"wDO7/ojLrFHcpjldqIMd5pt4F90O4iDchxcfD0J1DfW0cXuGdJDlxafk3tT4CpJ7" & @CRLF & _
"Dxrm7xO8vkrMqYvCfNSem8LxJ+MSnauvBlg4moYkdGCJAimkEkRpV0VK4bjjGrlu" & @CRLF & _
"0YMCggEAGftF1dJBqkUKc9dsbSQYwwfaU+W/gFWU4otTPd89HIOVkKyz3Hc0FrEH" & @CRLF & _
"68Ffrlx1MZU8wbNjjXytujJ7vwn0+n0bXN+5/oqEM+zlVunefCCLWWVLD0Sc/yOx" & @CRLF & _
"llgrU9u2z8Zjjl+mbbWNKhjV6oBNw3qi4CNHiBMHQk98xGQaRaTh/t/laXxZgtIo" & @CRLF & _
"Y+mZN7OXk3IUv6xlO+OyneG+CU9/VOPszLK9yFf95m9l5R6E6v9r4eE9N5OMOTxT" & @CRLF & _
"SBXZ+zNnnF4bIjy747KtCVI7XJQURDBbhhXick/lgX6sNj87vMaDJDnZ9kqqgc3U" & @CRLF & _
"1H23mg7nAvcEhsYClM3Z8/bEH6eRBQ==" & @CRLF & _
"-----END PRIVATE KEY-----" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")