#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{(.*?[a-zA-Z]+.*?)\}"
Local $sString = "Hello_mister,_Hello" & @CRLF & _
"{ Jack }" & @CRLF & _
"" & @CRLF & _
"ASD___asdfffasd" & @CRLF & _
"{this}{exam}{problem}{is}{boring}" & @CRLF & _
"" & @CRLF & _
"Whatsup_ddd_sup" & @CRLF & _
"{Dude}" & @CRLF & _
"" & @CRLF & _
"HeypalHey______how_ya_how_doin_how" & @CRLF & _
"{first}{second}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")