package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{(.*?[a-zA-Z]+.*?)\}`)
var str = `Hello_mister,_Hello
{ Jack }
ASD___asdfffasd
{this}{exam}{problem}{is}{boring}
Whatsup_ddd_sup
{Dude}
HeypalHey______how_ya_how_doin_how
{first}{second}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}