Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\{(.*?[a-zA-Z]+.*?)\}
/
g
Input 1
1
New
Hello_mister,_Hello { Jack } ASD___asdfffasd {this}{exam}{problem}{is}{boring} Whatsup_ddd_sup {Dude} HeypalHey______how_ya_how_doin_how {first}{second}