package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?<pat>[whlb])(?:\s*x\s*(?<pat>[whlb]))+\b`)
var str = `The measurements are (w x h x l): 5x7x3cm
The measurements, in form wxhxl: 5x7x3cm
Measurement options are (wxhxl), (hxlxb): Some random stuff
w x h x l x l x h`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}