$re = '/^(?:\d{1,3}(,\d{3})*|\d+|\d{2}(?:,\d{2})*,\d{3})(?:\.\d+)?$/m';
$str = '--valid--
1000
1000.12
1,000
1,000.12
10,000
10,000.12
10,000,000
10,000,000.12
10,00,00,000
10,00,00,000.12
--invalid--
100,
1000.
1000.12,
1000.12.34
1000,.12
,1000
,1000.12
1,,000
1,,00.12
.12
,,,,,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);