using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!w{1,3}\.)[\w-]+(?=\.example)";
string input = @"https://prefix.example.com
https://www.prefix.example.com
https://www.pre-fix.example.com
https://www.example.com
https://www.prefixnow.example.com
https://www.wonprefix.example.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}