$re = '/(?i)\/(?:i|package)(?:\s*"([^\\\\]+\\\\\s*.*?)"|\s+([^\\\\"]+\\\\.*?)\s)/m';
$str = '/i "package\\name" test
/i "package\\name" "test"
/i "package\\ name" test
/i "package\\ name" "test"
/I package\\name test
/package package\\name "test"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);